Install dependencies for MLT Multimedia Framework on CentOS 7


You can install dependencies to use theses modules.

1. SDL2-devel

[root@tutorialspots mlt-6.10.0]# yum install SDL2-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.host-engine.com
Resolving Dependencies
--> Running transaction check
---> Package SDL2-devel.x86_64 0:2.0.8-5.el7 will be installed
--> Processing Dependency: SDL2(x86-64) = 2.0.8-5.el7 for package: SDL2-devel-2.
0.8-5.el7.x86_64
--> Processing Dependency: mesa-libGLES-devel(x86-64) for package: SDL2-devel-2.
0.8-5.el7.x86_64
--> Processing Dependency: mesa-libEGL-devel(x86-64) for package: SDL2-devel-2.0
.8-5.el7.x86_64
--> Processing Dependency: libX11-devel(x86-64) for package: SDL2-devel-2.0.8-5.
el7.x86_64
--> Processing Dependency: libSDL2-2.0.so.0()(64bit) for package: SDL2-devel-2.0
.8-5.el7.x86_64
--> Running transaction check
---> Package SDL2.x86_64 0:2.0.8-5.el7 will be installed
---> Package libX11-devel.x86_64 0:1.6.5-1.el7 will be installed
--> Processing Dependency: pkgconfig(xcb) >= 1.11.1 for package: libX11-devel-1.
6.5-1.el7.x86_64
--> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.6.5-1.e
l7.x86_64
--> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.6.5-1.el7.
x86_64
--> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.6.5-1.
el7.x86_64
---> Package mesa-libEGL-devel.x86_64 0:17.2.3-8.20171019.el7 will be installed
--> Processing Dependency: pkgconfig(xdamage) >= 1.1 for package: mesa-libEGL-de
vel-17.2.3-8.20171019.el7.x86_64
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.75 for package: mesa-libEGL-
devel-17.2.3-8.20171019.el7.x86_64
--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libEGL-devel-17.
2.3-8.20171019.el7.x86_64
--> Processing Dependency: pkgconfig(xfixes) for package: mesa-libEGL-devel-17.2
.3-8.20171019.el7.x86_64
--> Processing Dependency: pkgconfig(xext) for package: mesa-libEGL-devel-17.2.3
-8.20171019.el7.x86_64
---> Package mesa-libGLES-devel.x86_64 0:17.2.3-8.20171019.el7 will be installed
--> Processing Dependency: mesa-libGLES = 17.2.3-8.20171019.el7 for package: mes
a-libGLES-devel-17.2.3-8.20171019.el7.x86_64
--> Processing Dependency: libGLESv2.so.2()(64bit) for package: mesa-libGLES-dev
el-17.2.3-8.20171019.el7.x86_64
--> Running transaction check
---> Package libXdamage-devel.x86_64 0:1.1.4-4.1.el7 will be installed
---> Package libXext-devel.x86_64 0:1.3.3-3.el7 will be installed
---> Package libXfixes-devel.x86_64 0:5.0.3-1.el7 will be installed
---> Package libXxf86vm-devel.x86_64 0:1.1.4-1.el7 will be installed
---> Package libdrm-devel.x86_64 0:2.4.83-2.el7 will be installed
---> Package libxcb-devel.x86_64 0:1.12-1.el7 will be installed
--> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.
12-1.el7.x86_64
---> Package mesa-libGLES.x86_64 0:17.2.3-8.20171019.el7 will be installed
---> Package xorg-x11-proto-devel.noarch 0:7.7-20.el7 will be installed
--> Running transaction check
---> Package libXau-devel.x86_64 0:1.0.8-2.1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch       Version                     Repository
                                                                           Size
================================================================================
Installing:
 SDL2-devel               x86_64     2.0.8-5.el7                 epel     251 k
Installing for dependencies:
 SDL2                     x86_64     2.0.8-5.el7                 epel     416 k
 libX11-devel             x86_64     1.6.5-1.el7                 base     980 k
 libXau-devel             x86_64     1.0.8-2.1.el7               base      14 k
 libXdamage-devel         x86_64     1.1.4-4.1.el7               base     9.7 k
 libXext-devel            x86_64     1.3.3-3.el7                 base      75 k
 libXfixes-devel          x86_64     5.0.3-1.el7                 base      13 k
 libXxf86vm-devel         x86_64     1.1.4-1.el7                 base      18 k
 libdrm-devel             x86_64     2.4.83-2.el7                base     128 k
 libxcb-devel             x86_64     1.12-1.el7                  base     1.0 M
 mesa-libEGL-devel        x86_64     17.2.3-8.20171019.el7       base      33 k
 mesa-libGLES             x86_64     17.2.3-8.20171019.el7       base      25 k
 mesa-libGLES-devel       x86_64     17.2.3-8.20171019.el7       base      57 k
 xorg-x11-proto-devel     noarch     7.7-20.el7                  base     284 k

Transaction Summary
================================================================================
Install  1 Package (+13 Dependent packages)

Total download size: 3.3 M
Installed size: 9.1 M
Downloading packages:
(1/14): SDL2-2.0.8-5.el7.x86_64.rpm                        | 416 kB   00:00
(2/14): SDL2-devel-2.0.8-5.el7.x86_64.rpm                  | 251 kB   00:00
(3/14): libXdamage-devel-1.1.4-4.1.el7.x86_64.rpm          | 9.7 kB   00:00
(4/14): libXau-devel-1.0.8-2.1.el7.x86_64.rpm              |  14 kB   00:00
(5/14): libXfixes-devel-5.0.3-1.el7.x86_64.rpm             |  13 kB   00:00
(6/14): libX11-devel-1.6.5-1.el7.x86_64.rpm                | 980 kB   00:00
(7/14): libXxf86vm-devel-1.1.4-1.el7.x86_64.rpm            |  18 kB   00:00
(8/14): libXext-devel-1.3.3-3.el7.x86_64.rpm               |  75 kB   00:00
(9/14): libdrm-devel-2.4.83-2.el7.x86_64.rpm               | 128 kB   00:00
(10/14): mesa-libEGL-devel-17.2.3-8.20171019.el7.x86_64.rp |  33 kB   00:00
(11/14): libxcb-devel-1.12-1.el7.x86_64.rpm                | 1.0 MB   00:00
(12/14): mesa-libGLES-devel-17.2.3-8.20171019.el7.x86_64.r |  57 kB   00:00
(13/14): mesa-libGLES-17.2.3-8.20171019.el7.x86_64.rpm     |  25 kB   00:00
(14/14): xorg-x11-proto-devel-7.7-20.el7.noarch.rpm        | 284 kB   00:00
--------------------------------------------------------------------------------
Total                                              3.0 MB/s | 3.3 MB  00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : xorg-x11-proto-devel-7.7-20.el7.noarch                      1/14
  Installing : libXau-devel-1.0.8-2.1.el7.x86_64                           2/14
  Installing : libxcb-devel-1.12-1.el7.x86_64                              3/14
  Installing : libX11-devel-1.6.5-1.el7.x86_64                             4/14
  Installing : libXfixes-devel-5.0.3-1.el7.x86_64                          5/14
  Installing : libXext-devel-1.3.3-3.el7.x86_64                            6/14
  Installing : libXxf86vm-devel-1.1.4-1.el7.x86_64                         7/14
  Installing : libXdamage-devel-1.1.4-4.1.el7.x86_64                       8/14
  Installing : SDL2-2.0.8-5.el7.x86_64                                     9/14
  Installing : libdrm-devel-2.4.83-2.el7.x86_64                           10/14
  Installing : mesa-libEGL-devel-17.2.3-8.20171019.el7.x86_64             11/14
  Installing : mesa-libGLES-17.2.3-8.20171019.el7.x86_64                  12/14
  Installing : mesa-libGLES-devel-17.2.3-8.20171019.el7.x86_64            13/14
  Installing : SDL2-devel-2.0.8-5.el7.x86_64                              14/14
  Verifying  : libXxf86vm-devel-1.1.4-1.el7.x86_64                         1/14
  Verifying  : libXfixes-devel-5.0.3-1.el7.x86_64                          2/14
  Verifying  : mesa-libGLES-17.2.3-8.20171019.el7.x86_64                   3/14
  Verifying  : libdrm-devel-2.4.83-2.el7.x86_64                            4/14
  Verifying  : xorg-x11-proto-devel-7.7-20.el7.noarch                      5/14
  Verifying  : SDL2-2.0.8-5.el7.x86_64                                     6/14
  Verifying  : libXext-devel-1.3.3-3.el7.x86_64                            7/14
  Verifying  : SDL2-devel-2.0.8-5.el7.x86_64                               8/14
  Verifying  : mesa-libGLES-devel-17.2.3-8.20171019.el7.x86_64             9/14
  Verifying  : libxcb-devel-1.12-1.el7.x86_64                             10/14
  Verifying  : mesa-libEGL-devel-17.2.3-8.20171019.el7.x86_64             11/14
  Verifying  : libXdamage-devel-1.1.4-4.1.el7.x86_64                      12/14
  Verifying  : libX11-devel-1.6.5-1.el7.x86_64                            13/14
  Verifying  : libXau-devel-1.0.8-2.1.el7.x86_64                          14/14

Installed:
  SDL2-devel.x86_64 0:2.0.8-5.el7

Dependency Installed:
  SDL2.x86_64 0:2.0.8-5.el7
  libX11-devel.x86_64 0:1.6.5-1.el7
  libXau-devel.x86_64 0:1.0.8-2.1.el7
  libXdamage-devel.x86_64 0:1.1.4-4.1.el7
  libXext-devel.x86_64 0:1.3.3-3.el7
  libXfixes-devel.x86_64 0:5.0.3-1.el7
  libXxf86vm-devel.x86_64 0:1.1.4-1.el7
  libdrm-devel.x86_64 0:2.4.83-2.el7
  libxcb-devel.x86_64 0:1.12-1.el7
  mesa-libEGL-devel.x86_64 0:17.2.3-8.20171019.el7
  mesa-libGLES.x86_64 0:17.2.3-8.20171019.el7
  mesa-libGLES-devel.x86_64 0:17.2.3-8.20171019.el7
  xorg-x11-proto-devel.noarch 0:7.7-20.el7

Complete!

2. libxml2-devel:

[root@tutorialspots mlt-6.10.0]# yum install libxml2-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package libxml2-devel.x86_64 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: xz-devel for package: libxml2-devel-2.9.1-6.el7_2.3.x
86_64
--> Running transaction check
---> Package xz-devel.x86_64 0:5.2.2-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch          Version                   Repository   Size
================================================================================
Installing:
 libxml2-devel        x86_64        2.9.1-6.el7_2.3           base        1.0 M
Installing for dependencies:
 xz-devel             x86_64        5.2.2-1.el7               base         46 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 1.1 M
Installed size: 8.9 M
Downloading packages:
(1/2): xz-devel-5.2.2-1.el7.x86_64.rpm                     |  46 kB   00:00
(2/2): libxml2-devel-2.9.1-6.el7_2.3.x86_64.rpm            | 1.0 MB   00:00
--------------------------------------------------------------------------------
Total                                              2.0 MB/s | 1.1 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : xz-devel-5.2.2-1.el7.x86_64                                  1/2
  Installing : libxml2-devel-2.9.1-6.el7_2.3.x86_64                         2/2
  Verifying  : xz-devel-5.2.2-1.el7.x86_64                                  1/2
  Verifying  : libxml2-devel-2.9.1-6.el7_2.3.x86_64                         2/2

Installed:
  libxml2-devel.x86_64 0:2.9.1-6.el7_2.3

Dependency Installed:
  xz-devel.x86_64 0:5.2.2-1.el7

Complete!

3. SDL-devel:

[root@tutorialspots mlt-6.10.0]# yum install SDL-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package SDL-devel.x86_64 0:1.2.15-14.el7 will be installed
--> Processing Dependency: mesa-libGLU-devel for package: SDL-devel-1.2.15-14.el
7.x86_64
--> Processing Dependency: mesa-libGL-devel for package: SDL-devel-1.2.15-14.el7
.x86_64
--> Processing Dependency: libXrender-devel for package: SDL-devel-1.2.15-14.el7
.x86_64
--> Processing Dependency: libXrandr-devel for package: SDL-devel-1.2.15-14.el7.
x86_64
--> Processing Dependency: alsa-lib-devel for package: SDL-devel-1.2.15-14.el7.x
86_64
--> Running transaction check
---> Package alsa-lib-devel.x86_64 0:1.1.4.1-2.el7 will be installed
---> Package libXrandr-devel.x86_64 0:1.5.1-2.el7 will be installed
--> Processing Dependency: libXrandr = 1.5.1-2.el7 for package: libXrandr-devel-
1.5.1-2.el7.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: libXrandr-devel-
1.5.1-2.el7.x86_64
---> Package libXrender-devel.x86_64 0:0.9.10-1.el7 will be installed
--> Processing Dependency: libXrender = 0.9.10-1.el7 for package: libXrender-dev
el-0.9.10-1.el7.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: libXrender-deve
l-0.9.10-1.el7.x86_64
---> Package mesa-libGL-devel.x86_64 0:17.2.3-8.20171019.el7 will be installed
--> Processing Dependency: gl-manpages for package: mesa-libGL-devel-17.2.3-8.20
171019.el7.x86_64
---> Package mesa-libGLU-devel.x86_64 0:9.0.0-4.el7 will be installed
--> Processing Dependency: mesa-libGLU(x86-64) = 9.0.0-4.el7 for package: mesa-l
ibGLU-devel-9.0.0-4.el7.x86_64
--> Processing Dependency: libGLU.so.1()(64bit) for package: mesa-libGLU-devel-9
.0.0-4.el7.x86_64
--> Running transaction check
---> Package gl-manpages.noarch 0:1.1-7.20130122.el7 will be installed
---> Package libXrandr.x86_64 0:1.5.1-2.el7 will be installed
---> Package libXrender.x86_64 0:0.9.10-1.el7 will be installed
---> Package mesa-libGLU.x86_64 0:9.0.0-4.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch        Version                     Repository
                                                                           Size
================================================================================
Installing:
 SDL-devel              x86_64      1.2.15-14.el7               base      355 k
Installing for dependencies:
 alsa-lib-devel         x86_64      1.1.4.1-2.el7               base      958 k
 gl-manpages            noarch      1.1-7.20130122.el7          base      994 k
 libXrandr              x86_64      1.5.1-2.el7                 base       27 k
 libXrandr-devel        x86_64      1.5.1-2.el7                 base       21 k
 libXrender             x86_64      0.9.10-1.el7                base       26 k
 libXrender-devel       x86_64      0.9.10-1.el7                base       17 k
 mesa-libGL-devel       x86_64      17.2.3-8.20171019.el7       base      157 k
 mesa-libGLU            x86_64      9.0.0-4.el7                 base      196 k
 mesa-libGLU-devel      x86_64      9.0.0-4.el7                 base      9.0 k

Transaction Summary
================================================================================
Install  1 Package (+9 Dependent packages)

Total download size: 2.7 M
Installed size: 18 M
Downloading packages:
(1/10): libXrandr-1.5.1-2.el7.x86_64.rpm                   |  27 kB   00:00
(2/10): SDL-devel-1.2.15-14.el7.x86_64.rpm                 | 355 kB   00:00
(3/10): alsa-lib-devel-1.1.4.1-2.el7.x86_64.rpm            | 958 kB   00:00
(4/10): libXrandr-devel-1.5.1-2.el7.x86_64.rpm             |  21 kB   00:00
(5/10): libXrender-0.9.10-1.el7.x86_64.rpm                 |  26 kB   00:00
(6/10): libXrender-devel-0.9.10-1.el7.x86_64.rpm           |  17 kB   00:00
(7/10): mesa-libGL-devel-17.2.3-8.20171019.el7.x86_64.rpm  | 157 kB   00:00
(8/10): mesa-libGLU-9.0.0-4.el7.x86_64.rpm                 | 196 kB   00:00
(9/10): mesa-libGLU-devel-9.0.0-4.el7.x86_64.rpm           | 9.0 kB   00:00
(10/10): gl-manpages-1.1-7.20130122.el7.noarch.rpm         | 994 kB   00:00
--------------------------------------------------------------------------------
Total                                              3.3 MB/s | 2.7 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libXrender-0.9.10-1.el7.x86_64                              1/10
  Installing : libXrender-devel-0.9.10-1.el7.x86_64                        2/10
  Installing : gl-manpages-1.1-7.20130122.el7.noarch                       3/10
  Installing : mesa-libGL-devel-17.2.3-8.20171019.el7.x86_64               4/10
  Installing : libXrandr-1.5.1-2.el7.x86_64                                5/10
  Installing : libXrandr-devel-1.5.1-2.el7.x86_64                          6/10
  Installing : mesa-libGLU-9.0.0-4.el7.x86_64                              7/10
  Installing : mesa-libGLU-devel-9.0.0-4.el7.x86_64                        8/10
  Installing : alsa-lib-devel-1.1.4.1-2.el7.x86_64                         9/10
  Installing : SDL-devel-1.2.15-14.el7.x86_64                             10/10
  Verifying  : libXrender-devel-0.9.10-1.el7.x86_64                        1/10
  Verifying  : libXrandr-devel-1.5.1-2.el7.x86_64                          2/10
  Verifying  : SDL-devel-1.2.15-14.el7.x86_64                              3/10
  Verifying  : alsa-lib-devel-1.1.4.1-2.el7.x86_64                         4/10
  Verifying  : libXrandr-1.5.1-2.el7.x86_64                                5/10
  Verifying  : gl-manpages-1.1-7.20130122.el7.noarch                       6/10
  Verifying  : mesa-libGLU-9.0.0-4.el7.x86_64                              7/10
  Verifying  : mesa-libGL-devel-17.2.3-8.20171019.el7.x86_64               8/10
  Verifying  : libXrender-0.9.10-1.el7.x86_64                              9/10
  Verifying  : mesa-libGLU-devel-9.0.0-4.el7.x86_64                       10/10

Installed:
  SDL-devel.x86_64 0:1.2.15-14.el7

Dependency Installed:
  alsa-lib-devel.x86_64 0:1.1.4.1-2.el7
  gl-manpages.noarch 0:1.1-7.20130122.el7
  libXrandr.x86_64 0:1.5.1-2.el7
  libXrandr-devel.x86_64 0:1.5.1-2.el7
  libXrender.x86_64 0:0.9.10-1.el7
  libXrender-devel.x86_64 0:0.9.10-1.el7
  mesa-libGL-devel.x86_64 0:17.2.3-8.20171019.el7
  mesa-libGLU.x86_64 0:9.0.0-4.el7
  mesa-libGLU-devel.x86_64 0:9.0.0-4.el7

Complete!

4. gtk2-devel

yum install gtk2-devel -y
...
--> Processing Dependency: libgailutil.so.18()(64bit) for package: gtk2-devel-2.
24.31-1.el7.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: gtk2-devel-2.24.3
1-1.el7.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: gtk2-devel-2.24
.31-1.el7.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-devel-2.2
4.31-1.el7.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-devel-2.24
.31-1.el7.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-devel-2
.24.31-1.el7.x86_64
--> Running transaction check
---> Package atk.x86_64 0:2.22.0-3.el7 will be installed
---> Package atk-devel.x86_64 0:2.22.0-3.el7 will be installed
---> Package cairo.x86_64 0:1.14.8-2.el7 will be installed
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.14.8-2
.el7.x86_64
---> Package cairo-devel.x86_64 0:1.14.8-2.el7 will be installed
--> Processing Dependency: pkgconfig(pixman-1) >= 0.30.0 for package: cairo-deve
l-1.14.8-2.el7.x86_64
--> Processing Dependency: pkgconfig(freetype2) >= 9.7.3 for package: cairo-deve
l-1.14.8-2.el7.x86_64
--> Processing Dependency: pkgconfig(fontconfig) >= 2.2.95 for package: cairo-de
vel-1.14.8-2.el7.x86_64
--> Processing Dependency: pkgconfig(libpng) for package: cairo-devel-1.14.8-2.e
l7.x86_64
---> Package gdk-pixbuf2.x86_64 0:2.36.5-1.el7 will be installed
--> Processing Dependency: libtiff.so.5(LIBTIFF_4.0)(64bit) for package: gdk-pix
buf2-2.36.5-1.el7.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: gdk-pixbuf2-2.36.5
-1.el7.x86_64
--> Processing Dependency: libjasper.so.1()(64bit) for package: gdk-pixbuf2-2.36
.5-1.el7.x86_64
---> Package gdk-pixbuf2-devel.x86_64 0:2.36.5-1.el7 will be installed
---> Package glib2-devel.x86_64 0:2.54.2-2.el7 will be installed
---> Package gtk2.x86_64 0:2.24.31-1.el7 will be installed
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.24.31-1.el7.x8
6_64
--> Processing Dependency: gtk-update-icon-cache for package: gtk2-2.24.31-1.el7
.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: gtk2-2.24.31-1.el7
.x86_64
---> Package libXcomposite.x86_64 0:0.4.4-4.1.el7 will be installed
---> Package libXcomposite-devel.x86_64 0:0.4.4-4.1.el7 will be installed
---> Package libXcursor.x86_64 0:1.1.14-8.el7 will be installed
---> Package libXcursor-devel.x86_64 0:1.1.14-8.el7 will be installed
---> Package libXi-devel.x86_64 0:1.7.9-1.el7 will be installed
---> Package libXinerama.x86_64 0:1.1.3-2.1.el7 will be installed
---> Package libXinerama-devel.x86_64 0:1.1.3-2.1.el7 will be installed
---> Package pango.x86_64 0:1.40.4-1.el7 will be installed
--> Processing Dependency: libthai(x86-64) >= 0.1.9 for package: pango-1.40.4-1.
el7.x86_64
--> Processing Dependency: libXft(x86-64) >= 2.0.0 for package: pango-1.40.4-1.e
l7.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1
.40.4-1.el7.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.40.4-1.el7
.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.40.4-1.el7.
x86_64
---> Package pango-devel.x86_64 0:1.40.4-1.el7 will be installed
--> Processing Dependency: pkgconfig(xft) for package: pango-devel-1.40.4-1.el7.
x86_64
--> Processing Dependency: pkgconfig(harfbuzz) for package: pango-devel-1.40.4-1
.el7.x86_64
--> Running transaction check
---> Package cups-libs.x86_64 1:1.6.3-35.el7 will be installed
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: 1:cups-lib
s-1.6.3-35.el7.x86_64
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: 1:cups-lib
s-1.6.3-35.el7.x86_64
---> Package fontconfig-devel.x86_64 0:2.10.95-11.el7 will be installed
--> Processing Dependency: pkgconfig(expat) for package: fontconfig-devel-2.10.9
5-11.el7.x86_64
---> Package freetype-devel.x86_64 0:2.4.11-15.el7 will be installed
---> Package gtk-update-icon-cache.x86_64 0:3.22.26-4.el7_5 will be installed
---> Package harfbuzz-devel.x86_64 0:1.3.2-1.el7 will be installed
--> Processing Dependency: harfbuzz-icu(x86-64) = 1.3.2-1.el7 for package: harfb
uzz-devel-1.3.2-1.el7.x86_64
--> Processing Dependency: pkgconfig(icu-uc) for package: harfbuzz-devel-1.3.2-1
.el7.x86_64
--> Processing Dependency: pkgconfig(graphite2) for package: harfbuzz-devel-1.3.
2-1.el7.x86_64
--> Processing Dependency: libharfbuzz-icu.so.0()(64bit) for package: harfbuzz-d
evel-1.3.2-1.el7.x86_64
---> Package hicolor-icon-theme.noarch 0:0.12-7.el7 will be installed
---> Package jasper-libs.x86_64 0:1.900.1-31.el7 will be installed
---> Package libXft.x86_64 0:2.3.2-2.el7 will be installed
---> Package libXft-devel.x86_64 0:2.3.2-2.el7 will be installed
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
---> Package libthai.x86_64 0:0.1.14-9.el7 will be installed
---> Package libtiff.x86_64 0:4.0.3-27.el7_3 will be installed
--> Processing Dependency: libjbig.so.2.0()(64bit) for package: libtiff-4.0.3-27
.el7_3.x86_64
---> Package pixman.x86_64 0:0.34.0-1.el7 will be installed
---> Package pixman-devel.x86_64 0:0.34.0-1.el7 will be installed
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.31-19.el7 will be installed
---> Package expat-devel.x86_64 0:2.1.0-10.el7_3 will be installed
---> Package graphite2-devel.x86_64 0:1.3.10-1.el7_3 will be installed
---> Package harfbuzz-icu.x86_64 0:1.3.2-1.el7 will be installed
---> Package jbigkit-libs.x86_64 0:2.0-11.el7 will be installed
---> Package libicu-devel.x86_64 0:50.1.2-15.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch       Version                 Repository   Size
================================================================================
Installing:
 gtk2-devel                x86_64     2.24.31-1.el7           base        3.0 M
Installing for dependencies:
 atk                       x86_64     2.22.0-3.el7            base        258 k
 atk-devel                 x86_64     2.22.0-3.el7            base        183 k
 avahi-libs                x86_64     0.6.31-19.el7           base         61 k
 cairo                     x86_64     1.14.8-2.el7            base        713 k
 cairo-devel               x86_64     1.14.8-2.el7            base        366 k
 cups-libs                 x86_64     1:1.6.3-35.el7          base        357 k
 expat-devel               x86_64     2.1.0-10.el7_3          base         57 k
 fontconfig-devel          x86_64     2.10.95-11.el7          base        128 k
 freetype-devel            x86_64     2.4.11-15.el7           base        356 k
 gdk-pixbuf2               x86_64     2.36.5-1.el7            base        567 k
 gdk-pixbuf2-devel         x86_64     2.36.5-1.el7            base        218 k
 glib2-devel               x86_64     2.54.2-2.el7            base        446 k
 graphite2-devel           x86_64     1.3.10-1.el7_3          base         40 k
 gtk-update-icon-cache     x86_64     3.22.26-4.el7_5         updates      27 k
 gtk2                      x86_64     2.24.31-1.el7           base        3.4 M
 harfbuzz-devel            x86_64     1.3.2-1.el7             base        134 k
 harfbuzz-icu              x86_64     1.3.2-1.el7             base         11 k
 hicolor-icon-theme        noarch     0.12-7.el7              base         42 k
 jasper-libs               x86_64     1.900.1-31.el7          base        150 k
 jbigkit-libs              x86_64     2.0-11.el7              base         46 k
 libXcomposite             x86_64     0.4.4-4.1.el7           base         22 k
 libXcomposite-devel       x86_64     0.4.4-4.1.el7           base         16 k
 libXcursor                x86_64     1.1.14-8.el7            base         30 k
 libXcursor-devel          x86_64     1.1.14-8.el7            base         24 k
 libXft                    x86_64     2.3.2-2.el7             base         58 k
 libXft-devel              x86_64     2.3.2-2.el7             base         19 k
 libXi-devel               x86_64     1.7.9-1.el7             base        105 k
 libXinerama               x86_64     1.1.3-2.1.el7           base         14 k
 libXinerama-devel         x86_64     1.1.3-2.1.el7           base         13 k
 libicu-devel              x86_64     50.1.2-15.el7           base        702 k
 libpng-devel              x86_64     2:1.5.13-7.el7_2        base        122 k
 libthai                   x86_64     0.1.14-9.el7            base        187 k
 libtiff                   x86_64     4.0.3-27.el7_3          base        170 k
 pango                     x86_64     1.40.4-1.el7            base        275 k
 pango-devel               x86_64     1.40.4-1.el7            base        316 k
 pixman                    x86_64     0.34.0-1.el7            base        248 k
 pixman-devel              x86_64     0.34.0-1.el7            base         20 k

Transaction Summary
================================================================================
Install  1 Package (+37 Dependent packages)

Total download size: 13 M
Installed size: 64 M
Downloading packages:
(1/38): avahi-libs-0.6.31-19.el7.x86_64.rpm                |  61 kB   00:00
(2/38): atk-devel-2.22.0-3.el7.x86_64.rpm                  | 183 kB   00:00
(3/38): atk-2.22.0-3.el7.x86_64.rpm                        | 258 kB   00:00
(4/38): expat-devel-2.1.0-10.el7_3.x86_64.rpm              |  57 kB   00:00
(5/38): cairo-devel-1.14.8-2.el7.x86_64.rpm                | 366 kB   00:00
(6/38): fontconfig-devel-2.10.95-11.el7.x86_64.rpm         | 128 kB   00:00
(7/38): freetype-devel-2.4.11-15.el7.x86_64.rpm            | 356 kB   00:00
(8/38): gdk-pixbuf2-devel-2.36.5-1.el7.x86_64.rpm          | 218 kB   00:00
(9/38): gdk-pixbuf2-2.36.5-1.el7.x86_64.rpm                | 567 kB   00:00
(10/38): glib2-devel-2.54.2-2.el7.x86_64.rpm               | 446 kB   00:00
(11/38): graphite2-devel-1.3.10-1.el7_3.x86_64.rpm         |  40 kB   00:00
(12/38): cups-libs-1.6.3-35.el7.x86_64.rpm                 | 357 kB   00:00
(13/38): gtk2-2.24.31-1.el7.x86_64.rpm                     | 3.4 MB   00:00
(14/38): gtk-update-icon-cache-3.22.26-4.el7_5.x86_64.rpm  |  27 kB   00:00
(15/38): gtk2-devel-2.24.31-1.el7.x86_64.rpm               | 3.0 MB   00:00
(16/38): harfbuzz-icu-1.3.2-1.el7.x86_64.rpm               |  11 kB   00:00
(17/38): hicolor-icon-theme-0.12-7.el7.noarch.rpm          |  42 kB   00:00
(18/38): jasper-libs-1.900.1-31.el7.x86_64.rpm             | 150 kB   00:00
(19/38): harfbuzz-devel-1.3.2-1.el7.x86_64.rpm             | 134 kB   00:00
(20/38): jbigkit-libs-2.0-11.el7.x86_64.rpm                |  46 kB   00:00
(21/38): libXcomposite-0.4.4-4.1.el7.x86_64.rpm            |  22 kB   00:00
(22/38): libXcomposite-devel-0.4.4-4.1.el7.x86_64.rpm      |  16 kB   00:00
(23/38): libXft-2.3.2-2.el7.x86_64.rpm                     |  58 kB   00:00
(24/38): libXcursor-devel-1.1.14-8.el7.x86_64.rpm          |  24 kB   00:00
(25/38): libXft-devel-2.3.2-2.el7.x86_64.rpm               |  19 kB   00:00
(26/38): libXi-devel-1.7.9-1.el7.x86_64.rpm                | 105 kB   00:00
(27/38): libXinerama-1.1.3-2.1.el7.x86_64.rpm              |  14 kB   00:00
(28/38): libXinerama-devel-1.1.3-2.1.el7.x86_64.rpm        |  13 kB   00:00
(29/38): libXcursor-1.1.14-8.el7.x86_64.rpm                |  30 kB   00:00
(30/38): libicu-devel-50.1.2-15.el7.x86_64.rpm             | 702 kB   00:00
(31/38): libtiff-4.0.3-27.el7_3.x86_64.rpm                 | 170 kB   00:00
(32/38): pango-1.40.4-1.el7.x86_64.rpm                     | 275 kB   00:00
(33/38): cairo-1.14.8-2.el7.x86_64.rpm                     | 713 kB   00:01
(34/38): libthai-0.1.14-9.el7.x86_64.rpm                   | 187 kB   00:00
(35/38): pango-devel-1.40.4-1.el7.x86_64.rpm               | 316 kB   00:00
(36/38): libpng-devel-1.5.13-7.el7_2.x86_64.rpm            | 122 kB   00:00
(37/38): pixman-devel-0.34.0-1.el7.x86_64.rpm              |  20 kB   00:00
(38/38): pixman-0.34.0-1.el7.x86_64.rpm                    | 248 kB   00:00
--------------------------------------------------------------------------------
Total                                              7.4 MB/s |  13 MB  00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : glib2-devel-2.54.2-2.el7.x86_64                             1/38
  Installing : freetype-devel-2.4.11-15.el7.x86_64                         2/38
  Installing : libXcursor-1.1.14-8.el7.x86_64                              3/38
  Installing : libXcomposite-0.4.4-4.1.el7.x86_64                          4/38
  Installing : libXinerama-1.1.3-2.1.el7.x86_64                            5/38
  Installing : atk-2.22.0-3.el7.x86_64                                     6/38
  Installing : pixman-0.34.0-1.el7.x86_64                                  7/38
  Installing : cairo-1.14.8-2.el7.x86_64                                   8/38
  Installing : 2:libpng-devel-1.5.13-7.el7_2.x86_64                        9/38
  Installing : libXft-2.3.2-2.el7.x86_64                                  10/38
  Installing : pixman-devel-0.34.0-1.el7.x86_64                           11/38
  Installing : atk-devel-2.22.0-3.el7.x86_64                              12/38
  Installing : libXinerama-devel-1.1.3-2.1.el7.x86_64                     13/38
  Installing : libXcomposite-devel-0.4.4-4.1.el7.x86_64                   14/38
  Installing : libXcursor-devel-1.1.14-8.el7.x86_64                       15/38
  Installing : libthai-0.1.14-9.el7.x86_64                                16/38
  Installing : pango-1.40.4-1.el7.x86_64                                  17/38
  Installing : libicu-devel-50.1.2-15.el7.x86_64                          18/38
  Installing : jbigkit-libs-2.0-11.el7.x86_64                             19/38
  Installing : libtiff-4.0.3-27.el7_3.x86_64                              20/38
  Installing : harfbuzz-icu-1.3.2-1.el7.x86_64                            21/38
  Installing : libXi-devel-1.7.9-1.el7.x86_64                             22/38
  Installing : jasper-libs-1.900.1-31.el7.x86_64                          23/38
  Installing : gdk-pixbuf2-2.36.5-1.el7.x86_64                            24/38
  Installing : gdk-pixbuf2-devel-2.36.5-1.el7.x86_64                      25/38
  Installing : gtk-update-icon-cache-3.22.26-4.el7_5.x86_64               26/38
  Installing : graphite2-devel-1.3.10-1.el7_3.x86_64                      27/38
  Installing : harfbuzz-devel-1.3.2-1.el7.x86_64                          28/38
  Installing : avahi-libs-0.6.31-19.el7.x86_64                            29/38
  Installing : 1:cups-libs-1.6.3-35.el7.x86_64                            30/38
  Installing : hicolor-icon-theme-0.12-7.el7.noarch                       31/38
  Installing : gtk2-2.24.31-1.el7.x86_64                                  32/38
  Installing : expat-devel-2.1.0-10.el7_3.x86_64                          33/38
  Installing : fontconfig-devel-2.10.95-11.el7.x86_64                     34/38
  Installing : cairo-devel-1.14.8-2.el7.x86_64                            35/38
  Installing : libXft-devel-2.3.2-2.el7.x86_64                            36/38
  Installing : pango-devel-1.40.4-1.el7.x86_64                            37/38
  Installing : gtk2-devel-2.24.31-1.el7.x86_64                            38/38
  Verifying  : libXft-devel-2.3.2-2.el7.x86_64                             1/38
  Verifying  : atk-2.22.0-3.el7.x86_64                                     2/38
  Verifying  : libtiff-4.0.3-27.el7_3.x86_64                               3/38
  Verifying  : pango-devel-1.40.4-1.el7.x86_64                             4/38
  Verifying  : harfbuzz-devel-1.3.2-1.el7.x86_64                           5/38
  Verifying  : libXinerama-1.1.3-2.1.el7.x86_64                            6/38
  Verifying  : libXcursor-devel-1.1.14-8.el7.x86_64                        7/38
  Verifying  : gtk2-2.24.31-1.el7.x86_64                                   8/38
  Verifying  : 1:cups-libs-1.6.3-35.el7.x86_64                             9/38
  Verifying  : expat-devel-2.1.0-10.el7_3.x86_64                          10/38
  Verifying  : hicolor-icon-theme-0.12-7.el7.noarch                       11/38
  Verifying  : cairo-1.14.8-2.el7.x86_64                                  12/38
  Verifying  : avahi-libs-0.6.31-19.el7.x86_64                            13/38
  Verifying  : gdk-pixbuf2-devel-2.36.5-1.el7.x86_64                      14/38
  Verifying  : graphite2-devel-1.3.10-1.el7_3.x86_64                      15/38
  Verifying  : gtk2-devel-2.24.31-1.el7.x86_64                            16/38
  Verifying  : jasper-libs-1.900.1-31.el7.x86_64                          17/38
  Verifying  : libXcomposite-0.4.4-4.1.el7.x86_64                         18/38
  Verifying  : glib2-devel-2.54.2-2.el7.x86_64                            19/38
  Verifying  : libXi-devel-1.7.9-1.el7.x86_64                             20/38
  Verifying  : libXft-2.3.2-2.el7.x86_64                                  21/38
  Verifying  : fontconfig-devel-2.10.95-11.el7.x86_64                     22/38
  Verifying  : libXcursor-1.1.14-8.el7.x86_64                             23/38
  Verifying  : libXinerama-devel-1.1.3-2.1.el7.x86_64                     24/38
  Verifying  : 2:libpng-devel-1.5.13-7.el7_2.x86_64                       25/38
  Verifying  : pango-1.40.4-1.el7.x86_64                                  26/38
  Verifying  : freetype-devel-2.4.11-15.el7.x86_64                        27/38
  Verifying  : atk-devel-2.22.0-3.el7.x86_64                              28/38
  Verifying  : gtk-update-icon-cache-3.22.26-4.el7_5.x86_64               29/38
  Verifying  : harfbuzz-icu-1.3.2-1.el7.x86_64                            30/38
  Verifying  : jbigkit-libs-2.0-11.el7.x86_64                             31/38
  Verifying  : gdk-pixbuf2-2.36.5-1.el7.x86_64                            32/38
  Verifying  : pixman-devel-0.34.0-1.el7.x86_64                           33/38
  Verifying  : libXcomposite-devel-0.4.4-4.1.el7.x86_64                   34/38
  Verifying  : libicu-devel-50.1.2-15.el7.x86_64                          35/38
  Verifying  : cairo-devel-1.14.8-2.el7.x86_64                            36/38
  Verifying  : libthai-0.1.14-9.el7.x86_64                                37/38
  Verifying  : pixman-0.34.0-1.el7.x86_64                                 38/38

Installed:
  gtk2-devel.x86_64 0:2.24.31-1.el7

Dependency Installed:
  atk.x86_64 0:2.22.0-3.el7
  atk-devel.x86_64 0:2.22.0-3.el7
  avahi-libs.x86_64 0:0.6.31-19.el7
  cairo.x86_64 0:1.14.8-2.el7
  cairo-devel.x86_64 0:1.14.8-2.el7
  cups-libs.x86_64 1:1.6.3-35.el7
  expat-devel.x86_64 0:2.1.0-10.el7_3
  fontconfig-devel.x86_64 0:2.10.95-11.el7
  freetype-devel.x86_64 0:2.4.11-15.el7
  gdk-pixbuf2.x86_64 0:2.36.5-1.el7
  gdk-pixbuf2-devel.x86_64 0:2.36.5-1.el7
  glib2-devel.x86_64 0:2.54.2-2.el7
  graphite2-devel.x86_64 0:1.3.10-1.el7_3
  gtk-update-icon-cache.x86_64 0:3.22.26-4.el7_5
  gtk2.x86_64 0:2.24.31-1.el7
  harfbuzz-devel.x86_64 0:1.3.2-1.el7
  harfbuzz-icu.x86_64 0:1.3.2-1.el7
  hicolor-icon-theme.noarch 0:0.12-7.el7
  jasper-libs.x86_64 0:1.900.1-31.el7
  jbigkit-libs.x86_64 0:2.0-11.el7
  libXcomposite.x86_64 0:0.4.4-4.1.el7
  libXcomposite-devel.x86_64 0:0.4.4-4.1.el7
  libXcursor.x86_64 0:1.1.14-8.el7
  libXcursor-devel.x86_64 0:1.1.14-8.el7
  libXft.x86_64 0:2.3.2-2.el7
  libXft-devel.x86_64 0:2.3.2-2.el7
  libXi-devel.x86_64 0:1.7.9-1.el7
  libXinerama.x86_64 0:1.1.3-2.1.el7
  libXinerama-devel.x86_64 0:1.1.3-2.1.el7
  libicu-devel.x86_64 0:50.1.2-15.el7
  libpng-devel.x86_64 2:1.5.13-7.el7_2
  libthai.x86_64 0:0.1.14-9.el7
  libtiff.x86_64 0:4.0.3-27.el7_3
  pango.x86_64 0:1.40.4-1.el7
  pango-devel.x86_64 0:1.40.4-1.el7
  pixman.x86_64 0:0.34.0-1.el7
  pixman-devel.x86_64 0:0.34.0-1.el7

Complete!

5. libexif-devel for modules/gtk2

[root@tutorialspots mlt-6.10.0]# yum install libexif-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.host-engine.com
Resolving Dependencies
--> Running transaction check
---> Package libexif-devel.x86_64 0:0.6.21-6.el7 will be installed
--> Processing Dependency: libexif(x86-64) = 0.6.21-6.el7 for package: libexif-d
evel-0.6.21-6.el7.x86_64
--> Processing Dependency: libexif.so.12()(64bit) for package: libexif-devel-0.6
.21-6.el7.x86_64
--> Running transaction check
---> Package libexif.x86_64 0:0.6.21-6.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch           Version                Repository    Size
================================================================================
Installing:
 libexif-devel         x86_64         0.6.21-6.el7           base          21 k
Installing for dependencies:
 libexif               x86_64         0.6.21-6.el7           base         347 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 368 k
Installed size: 1.9 M
Downloading packages:
(1/2): libexif-devel-0.6.21-6.el7.x86_64.rpm               |  21 kB   00:00
(2/2): libexif-0.6.21-6.el7.x86_64.rpm                     | 347 kB   00:00
--------------------------------------------------------------------------------
Total                                              803 kB/s | 368 kB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libexif-0.6.21-6.el7.x86_64                                  1/2
  Installing : libexif-devel-0.6.21-6.el7.x86_64                            2/2
  Verifying  : libexif-0.6.21-6.el7.x86_64                                  1/2
  Verifying  : libexif-devel-0.6.21-6.el7.x86_64                            2/2

Installed:
  libexif-devel.x86_64 0:0.6.21-6.el7

Dependency Installed:
  libexif.x86_64 0:0.6.21-6.el7

Complete!

6. frei0r-devel for modules/frei0r

[root@tutorialspots mlt-6.10.0]# yum install frei0r-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.host-engine.com
Resolving Dependencies
--> Running transaction check
---> Package frei0r-devel.x86_64 0:1.3-13.el7 will be installed
--> Processing Dependency: frei0r-plugins = 1.3-13.el7 for package: frei0r-devel
-1.3-13.el7.x86_64
--> Running transaction check
---> Package frei0r-plugins.x86_64 0:1.3-13.el7 will be installed
--> Processing Dependency: libgavl.so.1()(64bit) for package: frei0r-plugins-1.3
-13.el7.x86_64
--> Running transaction check
---> Package gavl.x86_64 0:1.4.0-4.el7 will be installed
--> Processing Dependency: libgdither.so.1()(64bit) for package: gavl-1.4.0-4.el
7.x86_64
--> Running transaction check
---> Package libgdither.x86_64 0:0.6-8.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch           Version               Repository    Size
================================================================================
Installing:
 frei0r-devel           x86_64         1.3-13.el7            base          12 k
Installing for dependencies:
 frei0r-plugins         x86_64         1.3-13.el7            base         458 k
 gavl                   x86_64         1.4.0-4.el7           base         2.6 M
 libgdither             x86_64         0.6-8.el7             base          20 k

Transaction Summary
================================================================================
Install  1 Package (+3 Dependent packages)

Total download size: 3.1 M
Installed size: 9.3 M
Downloading packages:
(1/4): frei0r-devel-1.3-13.el7.x86_64.rpm                  |  12 kB   00:00
(2/4): libgdither-0.6-8.el7.x86_64.rpm                     |  20 kB   00:00
(3/4): frei0r-plugins-1.3-13.el7.x86_64.rpm                | 458 kB   00:00
(4/4): gavl-1.4.0-4.el7.x86_64.rpm                         | 2.6 MB   00:01
--------------------------------------------------------------------------------
Total                                              2.7 MB/s | 3.1 MB  00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libgdither-0.6-8.el7.x86_64                                  1/4
  Installing : gavl-1.4.0-4.el7.x86_64                                      2/4
  Installing : frei0r-plugins-1.3-13.el7.x86_64                             3/4
  Installing : frei0r-devel-1.3-13.el7.x86_64                               4/4
  Verifying  : libgdither-0.6-8.el7.x86_64                                  1/4
  Verifying  : frei0r-devel-1.3-13.el7.x86_64                               2/4
  Verifying  : gavl-1.4.0-4.el7.x86_64                                      3/4
  Verifying  : frei0r-plugins-1.3-13.el7.x86_64                             4/4

Installed:
  frei0r-devel.x86_64 0:1.3-13.el7

Dependency Installed:
  frei0r-plugins.x86_64 0:1.3-13.el7          gavl.x86_64 0:1.4.0-4.el7
  libgdither.x86_64 0:0.6-8.el7

Complete!

7. fftw-devel for modules/qt

[root@tutorialspots mlt-6.10.0]# yum install fftw-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package fftw-devel.x86_64 0:3.3.3-8.el7 will be installed
--> Processing Dependency: fftw-libs(x86-64) = 3.3.3-8.el7 for package: fftw-dev
el-3.3.3-8.el7.x86_64
--> Processing Dependency: fftw(x86-64) = 3.3.3-8.el7 for package: fftw-devel-3.
3.3-8.el7.x86_64
--> Processing Dependency: libfftw3l_threads.so.3()(64bit) for package: fftw-dev
el-3.3.3-8.el7.x86_64
--> Processing Dependency: libfftw3l_omp.so.3()(64bit) for package: fftw-devel-3
.3.3-8.el7.x86_64
--> Processing Dependency: libfftw3l.so.3()(64bit) for package: fftw-devel-3.3.3
-8.el7.x86_64
--> Processing Dependency: libfftw3f_threads.so.3()(64bit) for package: fftw-dev
el-3.3.3-8.el7.x86_64
--> Processing Dependency: libfftw3f_omp.so.3()(64bit) for package: fftw-devel-3
.3.3-8.el7.x86_64
--> Processing Dependency: libfftw3f.so.3()(64bit) for package: fftw-devel-3.3.3
-8.el7.x86_64
--> Processing Dependency: libfftw3_threads.so.3()(64bit) for package: fftw-deve
l-3.3.3-8.el7.x86_64
--> Processing Dependency: libfftw3_omp.so.3()(64bit) for package: fftw-devel-3.
3.3-8.el7.x86_64
--> Processing Dependency: libfftw3.so.3()(64bit) for package: fftw-devel-3.3.3-
8.el7.x86_64
--> Running transaction check
---> Package fftw.x86_64 0:3.3.3-8.el7 will be installed
---> Package fftw-libs.x86_64 0:3.3.3-8.el7 will be installed
---> Package fftw-libs-double.x86_64 0:3.3.3-8.el7 will be installed
---> Package fftw-libs-long.x86_64 0:3.3.3-8.el7 will be installed
---> Package fftw-libs-single.x86_64 0:3.3.3-8.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch           Version             Repository    Size
================================================================================
Installing:
 fftw-devel               x86_64         3.3.3-8.el7         base         128 k
Installing for dependencies:
 fftw                     x86_64         3.3.3-8.el7         base          45 k
 fftw-libs                x86_64         3.3.3-8.el7         base         8.5 k
 fftw-libs-double         x86_64         3.3.3-8.el7         base         759 k
 fftw-libs-long           x86_64         3.3.3-8.el7         base         495 k
 fftw-libs-single         x86_64         3.3.3-8.el7         base         766 k

Transaction Summary
================================================================================
Install  1 Package (+5 Dependent packages)

Total download size: 2.1 M
Installed size: 6.8 M
Downloading packages:
(1/6): fftw-3.3.3-8.el7.x86_64.rpm                         |  45 kB   00:00
(2/6): fftw-libs-3.3.3-8.el7.x86_64.rpm                    | 8.5 kB   00:00
(3/6): fftw-devel-3.3.3-8.el7.x86_64.rpm                   | 128 kB   00:00
(4/6): fftw-libs-double-3.3.3-8.el7.x86_64.rpm             | 759 kB   00:00
(5/6): fftw-libs-long-3.3.3-8.el7.x86_64.rpm               | 495 kB   00:00
(6/6): fftw-libs-single-3.3.3-8.el7.x86_64.rpm             | 766 kB   00:00
--------------------------------------------------------------------------------
Total                                              3.8 MB/s | 2.1 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : fftw-libs-long-3.3.3-8.el7.x86_64                            1/6
  Installing : fftw-libs-single-3.3.3-8.el7.x86_64                          2/6
  Installing : fftw-libs-double-3.3.3-8.el7.x86_64                          3/6
  Installing : fftw-3.3.3-8.el7.x86_64                                      4/6
  Installing : fftw-libs-3.3.3-8.el7.x86_64                                 5/6
  Installing : fftw-devel-3.3.3-8.el7.x86_64                                6/6
  Verifying  : fftw-devel-3.3.3-8.el7.x86_64                                1/6
  Verifying  : fftw-libs-double-3.3.3-8.el7.x86_64                          2/6
  Verifying  : fftw-libs-single-3.3.3-8.el7.x86_64                          3/6
  Verifying  : fftw-libs-long-3.3.3-8.el7.x86_64                            4/6
  Verifying  : fftw-3.3.3-8.el7.x86_64                                      5/6
  Verifying  : fftw-libs-3.3.3-8.el7.x86_64                                 6/6

Installed:
  fftw-devel.x86_64 0:3.3.3-8.el7

Dependency Installed:
  fftw.x86_64 0:3.3.3-8.el7               fftw-libs.x86_64 0:3.3.3-8.el7
  fftw-libs-double.x86_64 0:3.3.3-8.el7   fftw-libs-long.x86_64 0:3.3.3-8.el7
  fftw-libs-single.x86_64 0:3.3.3-8.el7

Complete!

8. libebur128-devel for modules/plus

[root@s126368 mlt-6.10.0]# yum install libebur128-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package libebur128-devel.x86_64 0:1.2.3-1.el7 will be installed
--> Processing Dependency: libebur128(x86-64) = 1.2.3-1.el7 for package: libebur
128-devel-1.2.3-1.el7.x86_64
--> Processing Dependency: libebur128.so.1()(64bit) for package: libebur128-deve
l-1.2.3-1.el7.x86_64
--> Running transaction check
---> Package libebur128.x86_64 0:1.2.3-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch           Version             Repository    Size
================================================================================
Installing:
 libebur128-devel         x86_64         1.2.3-1.el7         epel         7.6 k
Installing for dependencies:
 libebur128               x86_64         1.2.3-1.el7         epel          19 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 26 k
Installed size: 46 k
Downloading packages:
(1/2): libebur128-1.2.3-1.el7.x86_64.rpm                   |  19 kB   00:00
(2/2): libebur128-devel-1.2.3-1.el7.x86_64.rpm             | 7.6 kB   00:00
--------------------------------------------------------------------------------
Total                                               74 kB/s |  26 kB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libebur128-1.2.3-1.el7.x86_64                                1/2
  Installing : libebur128-devel-1.2.3-1.el7.x86_64                          2/2
  Verifying  : libebur128-devel-1.2.3-1.el7.x86_64                          1/2
  Verifying  : libebur128-1.2.3-1.el7.x86_64                                2/2

Installed:
  libebur128-devel.x86_64 0:1.2.3-1.el7

Dependency Installed:
  libebur128.x86_64 0:1.2.3-1.el7

Complete!

9. jack-audio-connection-kit-devel for modules/jackrack

[root@s126368 mlt-6.10.0]# yum install jack-audio-connection-kit-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package jack-audio-connection-kit-devel.x86_64 0:1.9.9.5-6.el7 will be inst
alled
--> Processing Dependency: jack-audio-connection-kit = 1.9.9.5-6.el7 for package
: jack-audio-connection-kit-devel-1.9.9.5-6.el7.x86_64
--> Processing Dependency: libjackserver.so.0()(64bit) for package: jack-audio-c
onnection-kit-devel-1.9.9.5-6.el7.x86_64
--> Processing Dependency: libjacknet.so.0()(64bit) for package: jack-audio-conn
ection-kit-devel-1.9.9.5-6.el7.x86_64
--> Processing Dependency: libjack.so.0()(64bit) for package: jack-audio-connect
ion-kit-devel-1.9.9.5-6.el7.x86_64
--> Running transaction check
---> Package jack-audio-connection-kit.x86_64 0:1.9.9.5-6.el7 will be installed
--> Processing Dependency: libsamplerate.so.0(libsamplerate.so.0.0)(64bit) for p
ackage: jack-audio-connection-kit-1.9.9.5-6.el7.x86_64
--> Processing Dependency: libsamplerate.so.0()(64bit) for package: jack-audio-c
onnection-kit-1.9.9.5-6.el7.x86_64
--> Processing Dependency: libffado.so.2()(64bit) for package: jack-audio-connec
tion-kit-1.9.9.5-6.el7.x86_64
--> Running transaction check
---> Package libffado.x86_64 0:2.1.0-4.el7 will be installed
--> Processing Dependency: libxml++-2.6.so.2()(64bit) for package: libffado-2.1.
0-4.el7.x86_64
--> Processing Dependency: libsigc-2.0.so.0()(64bit) for package: libffado-2.1.0
-4.el7.x86_64
--> Processing Dependency: libiec61883.so.0()(64bit) for package: libffado-2.1.0
-4.el7.x86_64
--> Processing Dependency: libglibmm-2.4.so.1()(64bit) for package: libffado-2.1
.0-4.el7.x86_64
--> Processing Dependency: libconfig++.so.9()(64bit) for package: libffado-2.1.0
-4.el7.x86_64
---> Package libsamplerate.x86_64 0:0.1.8-6.el7 will be installed
--> Running transaction check
---> Package glibmm24.x86_64 0:2.50.0-1.el7 will be installed
---> Package libconfig.x86_64 0:1.4.9-5.el7 will be installed
---> Package libiec61883.x86_64 0:1.2.0-10.el7 will be installed
---> Package libsigc++20.x86_64 0:2.10.0-1.el7 will be installed
---> Package libxml++.x86_64 0:2.37.1-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                            Arch      Version             Repository
                                                                           Size
================================================================================
Installing:
 jack-audio-connection-kit-devel    x86_64    1.9.9.5-6.el7       epel    181 k
Installing for dependencies:
 glibmm24                           x86_64    2.50.0-1.el7        base    526 k
 jack-audio-connection-kit          x86_64    1.9.9.5-6.el7       epel    522 k
 libconfig                          x86_64    1.4.9-5.el7         base     59 k
 libffado                           x86_64    2.1.0-4.el7         epel    650 k
 libiec61883                        x86_64    1.2.0-10.el7        base     37 k
 libsamplerate                      x86_64    0.1.8-6.el7         base    1.0 M
 libsigc++20                        x86_64    2.10.0-1.el7        base     37 k
 libxml++                           x86_64    2.37.1-1.el7        epel     99 k

Transaction Summary
================================================================================
Install  1 Package (+8 Dependent packages)

Total download size: 3.1 M
Installed size: 10 M
Downloading packages:
(1/9): jack-audio-connection-kit-1.9.9.5-6.el7.x86_64.rpm  | 522 kB   00:00
(2/9): glibmm24-2.50.0-1.el7.x86_64.rpm                    | 526 kB   00:00
(3/9): jack-audio-connection-kit-devel-1.9.9.5-6.el7.x86_6 | 181 kB   00:00
(4/9): libiec61883-1.2.0-10.el7.x86_64.rpm                 |  37 kB   00:00
(5/9): libffado-2.1.0-4.el7.x86_64.rpm                     | 650 kB   00:00
(6/9): libsamplerate-0.1.8-6.el7.x86_64.rpm                | 1.0 MB   00:00
(7/9): libconfig-1.4.9-5.el7.x86_64.rpm                    |  59 kB   00:00
(8/9): libsigc++20-2.10.0-1.el7.x86_64.rpm                 |  37 kB   00:00
(9/9): libxml++-2.37.1-1.el7.x86_64.rpm                    |  99 kB   00:00
--------------------------------------------------------------------------------
Total                                              4.0 MB/s | 3.1 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libsigc++20-2.10.0-1.el7.x86_64                              1/9
  Installing : glibmm24-2.50.0-1.el7.x86_64                                 2/9
  Installing : libxml++-2.37.1-1.el7.x86_64                                 3/9
  Installing : libsamplerate-0.1.8-6.el7.x86_64                             4/9
  Installing : libiec61883-1.2.0-10.el7.x86_64                              5/9
  Installing : libconfig-1.4.9-5.el7.x86_64                                 6/9
  Installing : libffado-2.1.0-4.el7.x86_64                                  7/9
  Installing : jack-audio-connection-kit-1.9.9.5-6.el7.x86_64               8/9
  Installing : jack-audio-connection-kit-devel-1.9.9.5-6.el7.x86_64         9/9
  Verifying  : libffado-2.1.0-4.el7.x86_64                                  1/9
  Verifying  : libconfig-1.4.9-5.el7.x86_64                                 2/9
  Verifying  : libiec61883-1.2.0-10.el7.x86_64                              3/9
  Verifying  : glibmm24-2.50.0-1.el7.x86_64                                 4/9
  Verifying  : libsamplerate-0.1.8-6.el7.x86_64                             5/9
  Verifying  : libsigc++20-2.10.0-1.el7.x86_64                              6/9
  Verifying  : libxml++-2.37.1-1.el7.x86_64                                 7/9
  Verifying  : jack-audio-connection-kit-1.9.9.5-6.el7.x86_64               8/9
  Verifying  : jack-audio-connection-kit-devel-1.9.9.5-6.el7.x86_64         9/9

Installed:
  jack-audio-connection-kit-devel.x86_64 0:1.9.9.5-6.el7

Dependency Installed:
  glibmm24.x86_64 0:2.50.0-1.el7
  jack-audio-connection-kit.x86_64 0:1.9.9.5-6.el7
  libconfig.x86_64 0:1.4.9-5.el7
  libffado.x86_64 0:2.1.0-4.el7
  libiec61883.x86_64 0:1.2.0-10.el7
  libsamplerate.x86_64 0:0.1.8-6.el7
  libsigc++20.x86_64 0:2.10.0-1.el7
  libxml++.x86_64 0:2.37.1-1.el7

Complete!

10. sox-devel for modules/sox

[root@tutorialspots mlt-6.10.0]# yum install sox-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * epel: mirror.compevo.com
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
Resolving Dependencies
--> Running transaction check
---> Package sox-devel.x86_64 0:14.4.1-6.el7 will be installed
--> Processing Dependency: sox = 14.4.1-6.el7 for package: sox-devel-14.4.1-6.el
7.x86_64
--> Processing Dependency: libsox.so.2()(64bit) for package: sox-devel-14.4.1-6.
el7.x86_64
--> Running transaction check
---> Package sox.x86_64 0:14.4.1-6.el7 will be installed
--> Processing Dependency: libao.so.4(LIBAO4_1.1.0)(64bit) for package: sox-14.4
.1-6.el7.x86_64
--> Processing Dependency: libwavpack.so.1()(64bit) for package: sox-14.4.1-6.el
7.x86_64
--> Processing Dependency: libao.so.4()(64bit) for package: sox-14.4.1-6.el7.x86
_64
--> Running transaction check
---> Package libao.x86_64 0:1.1.0-8.el7 will be installed
---> Package wavpack.x86_64 0:4.60.1-9.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch            Version                 Repository     Size
================================================================================
Installing:
 sox-devel          x86_64          14.4.1-6.el7            base           36 k
Installing for dependencies:
 libao              x86_64          1.1.0-8.el7             base           72 k
 sox                x86_64          14.4.1-6.el7            base          398 k
 wavpack            x86_64          4.60.1-9.el7            base          131 k

Transaction Summary
================================================================================
Install  1 Package (+3 Dependent packages)

Total download size: 637 k
Installed size: 1.6 M
Downloading packages:
(1/4): libao-1.1.0-8.el7.x86_64.rpm                        |  72 kB   00:00
(2/4): sox-devel-14.4.1-6.el7.x86_64.rpm                   |  36 kB   00:00
(3/4): sox-14.4.1-6.el7.x86_64.rpm                         | 398 kB   00:00
(4/4): wavpack-4.60.1-9.el7.x86_64.rpm                     | 131 kB   00:00
--------------------------------------------------------------------------------
Total                                              1.2 MB/s | 637 kB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libao-1.1.0-8.el7.x86_64                                     1/4
  Installing : wavpack-4.60.1-9.el7.x86_64                                  2/4
  Installing : sox-14.4.1-6.el7.x86_64                                      3/4
  Installing : sox-devel-14.4.1-6.el7.x86_64                                4/4
  Verifying  : wavpack-4.60.1-9.el7.x86_64                                  1/4
  Verifying  : sox-14.4.1-6.el7.x86_64                                      2/4
  Verifying  : sox-devel-14.4.1-6.el7.x86_64                                3/4
  Verifying  : libao-1.1.0-8.el7.x86_64                                     4/4

Installed:
  sox-devel.x86_64 0:14.4.1-6.el7

Dependency Installed:
  libao.x86_64 0:1.1.0-8.el7               sox.x86_64 0:14.4.1-6.el7
  wavpack.x86_64 0:4.60.1-9.el7

Complete!

11. movit
How to install Movit on CentOS 7

12. ladspa-devel

[root@tutorialspots mlt-6.10.0]# yum install ladspa-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                     |  18 kB     00:00
 * base: centos.mirror.lstn.net
 * epel: kdeforge2.unl.edu
 * extras: repo.us.bigstepcloud.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: repo.us.bigstepcloud.com
base                                                     | 3.6 kB     00:00
extras                                                   | 3.4 kB     00:00
ius                                                      | 2.3 kB     00:00
mysql-connectors-community                               | 2.5 kB     00:00
mysql-tools-community                                    | 2.5 kB     00:00
mysql57-community                                        | 2.5 kB     00:00
nodesource                                               | 2.5 kB     00:00
nux-dextop                                               | 2.9 kB     00:00
remi-safe                                                | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
ius/x86_64/primary_db                                      | 392 kB   00:00
Resolving Dependencies
--> Running transaction check
---> Package ladspa-devel.x86_64 0:1.13-12.el7 will be installed
--> Processing Dependency: ladspa = 1.13-12.el7 for package: ladspa-devel-1.13-1
2.el7.x86_64
--> Running transaction check
---> Package ladspa.x86_64 0:1.13-12.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch            Version              Repository     Size
================================================================================
Installing:
 ladspa-devel          x86_64          1.13-12.el7          base           19 k
Installing for dependencies:
 ladspa                x86_64          1.13-12.el7          base           43 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 62 k
Installed size: 156 k
Downloading packages:
(1/2): ladspa-devel-1.13-12.el7.x86_64.rpm                 |  19 kB   00:00
(2/2): ladspa-1.13-12.el7.x86_64.rpm                       |  43 kB   00:00
--------------------------------------------------------------------------------
Total                                              162 kB/s |  62 kB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ladspa-1.13-12.el7.x86_64                                    1/2
  Installing : ladspa-devel-1.13-12.el7.x86_64                              2/2
  Verifying  : ladspa-devel-1.13-12.el7.x86_64                              1/2
  Verifying  : ladspa-1.13-12.el7.x86_64                                    2/2

Installed:
  ladspa-devel.x86_64 0:1.13-12.el7

Dependency Installed:
  ladspa.x86_64 0:1.13-12.el7

Complete!

13. swfdec for modules/swfdec
How to install Swfdec on CentOS 7

14. pulseaudio-libs-devel

yum install pulseaudio-libs-devel -y

15. mesa-dri-drivers

[root@tutorialspots /]# yum install -y mesa-dri-drivers
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                     |  17 kB     00:00
 * base: mirror.compevo.com
 * epel: fedora-epel.mirror.lstn.net
 * extras: centos.host-engine.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.mirrors.tds.net
base                                                     | 3.6 kB     00:00
extras                                                   | 3.4 kB     00:00
ius                                                      | 2.3 kB     00:00
mysql-connectors-community                               | 2.5 kB     00:00
mysql-tools-community                                    | 2.5 kB     00:00
mysql57-community                                        | 2.5 kB     00:00
nodesource                                               | 2.5 kB     00:00
nux-dextop                                               | 2.9 kB     00:00
remi-safe                                                | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
(1/2): ius/x86_64/primary_db                               | 392 kB   00:00
(2/2): remi-safe/7/primary_db                              | 1.3 MB   00:01
Resolving Dependencies
--> Running transaction check
---> Package mesa-dri-drivers.x86_64 0:17.2.3-8.20171019.el7 will be installed
--> Processing Dependency: mesa-filesystem(x86-64) for package: mesa-dri-drivers
-17.2.3-8.20171019.el7.x86_64
--> Processing Dependency: libLLVM-5.0-rhel.so(LLVM_5.0)(64bit) for package: mes
a-dri-drivers-17.2.3-8.20171019.el7.x86_64
--> Processing Dependency: libLLVM-5.0-rhel.so()(64bit) for package: mesa-dri-dr
ivers-17.2.3-8.20171019.el7.x86_64
--> Running transaction check
---> Package llvm-private.x86_64 0:5.0.0-3.el7 will be installed
---> Package mesa-filesystem.x86_64 0:17.2.3-8.20171019.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch        Version                      Repository
                                                                           Size
================================================================================
Installing:
 mesa-dri-drivers      x86_64      17.2.3-8.20171019.el7        base      6.2 M
Installing for dependencies:
 llvm-private          x86_64      5.0.0-3.el7                  base       20 M
 mesa-filesystem       x86_64      17.2.3-8.20171019.el7        base       16 k

Transaction Summary
================================================================================
Install  1 Package (+2 Dependent packages)

Total download size: 26 M
Installed size: 89 M
Downloading packages:
(1/3): mesa-dri-drivers-17.2.3-8.20171019.el7.x86_64.rpm   | 6.2 MB   00:00
(2/3): mesa-filesystem-17.2.3-8.20171019.el7.x86_64.rpm    |  16 kB   00:00
(3/3): llvm-private-5.0.0-3.el7.x86_64.rpm                 |  20 MB   00:00
--------------------------------------------------------------------------------
Total                                               32 MB/s |  26 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : mesa-filesystem-17.2.3-8.20171019.el7.x86_64                 1/3
  Installing : llvm-private-5.0.0-3.el7.x86_64                              2/3
  Installing : mesa-dri-drivers-17.2.3-8.20171019.el7.x86_64                3/3
  Verifying  : llvm-private-5.0.0-3.el7.x86_64                              1/3
  Verifying  : mesa-filesystem-17.2.3-8.20171019.el7.x86_64                 2/3
  Verifying  : mesa-dri-drivers-17.2.3-8.20171019.el7.x86_64                3/3

Installed:
  mesa-dri-drivers.x86_64 0:17.2.3-8.20171019.el7

Dependency Installed:
  llvm-private.x86_64 0:5.0.0-3.el7
  mesa-filesystem.x86_64 0:17.2.3-8.20171019.el7

Complete!

16. alsa-plugins-pulseaudio

[root@tutorialspots ~]# yum install alsa-plugins-pulseaudio -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.compevo.com
 * epel: fedora-epel.mirror.lstn.net
 * extras: centos.host-engine.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.mirrors.tds.net
Resolving Dependencies
--> Running transaction check
---> Package alsa-plugins-pulseaudio.x86_64 0:1.1.1-1.el7 will be installed
--> Processing Dependency: pulseaudio for package: alsa-plugins-pulseaudio-1.1.1
-1.el7.x86_64
--> Processing Dependency: alsa-utils for package: alsa-plugins-pulseaudio-1.1.1
-1.el7.x86_64
--> Running transaction check
---> Package alsa-utils.x86_64 0:1.1.3-2.el7 will be installed
---> Package pulseaudio.x86_64 0:10.0-5.el7 will be installed
--> Processing Dependency: rtkit for package: pulseaudio-10.0-5.el7.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.1)(64bit) for package: pulseaudio
-10.0-5.el7.x86_64
--> Processing Dependency: libwebrtc_audio_processing.so.1()(64bit) for package:
 pulseaudio-10.0-5.el7.x86_64
--> Processing Dependency: libtdb.so.1()(64bit) for package: pulseaudio-10.0-5.e
l7.x86_64
--> Running transaction check
---> Package libtdb.x86_64 0:1.3.15-1.el7 will be installed
---> Package rtkit.x86_64 0:0.11-10.el7 will be installed
---> Package webrtc-audio-processing.x86_64 0:0.3-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                       Arch         Version            Repository  Size
================================================================================
Installing:
 alsa-plugins-pulseaudio       x86_64       1.1.1-1.el7        base        41 k
Installing for dependencies:
 alsa-utils                    x86_64       1.1.3-2.el7        base       1.0 M
 libtdb                        x86_64       1.3.15-1.el7       base        48 k
 pulseaudio                    x86_64       10.0-5.el7         base       924 k
 rtkit                         x86_64       0.11-10.el7        base        51 k
 webrtc-audio-processing       x86_64       0.3-1.el7          base       286 k

Transaction Summary
================================================================================
Install  1 Package (+5 Dependent packages)

Total download size: 2.4 M
Installed size: 6.2 M
Downloading packages:
(1/6): alsa-plugins-pulseaudio-1.1.1-1.el7.x86_64.rpm      |  41 kB   00:00
(2/6): libtdb-1.3.15-1.el7.x86_64.rpm                      |  48 kB   00:00
(3/6): pulseaudio-10.0-5.el7.x86_64.rpm                    | 924 kB   00:00
(4/6): rtkit-0.11-10.el7.x86_64.rpm                        |  51 kB   00:00
(5/6): webrtc-audio-processing-0.3-1.el7.x86_64.rpm        | 286 kB   00:00
(6/6): alsa-utils-1.1.3-2.el7.x86_64.rpm                   | 1.0 MB   00:01
--------------------------------------------------------------------------------
Total                                              1.7 MB/s | 2.4 MB  00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : rtkit-0.11-10.el7.x86_64                                     1/6
  Installing : webrtc-audio-processing-0.3-1.el7.x86_64                     2/6
  Installing : libtdb-1.3.15-1.el7.x86_64                                   3/6
  Installing : pulseaudio-10.0-5.el7.x86_64                                 4/6
  Installing : alsa-utils-1.1.3-2.el7.x86_64                                5/6
  Installing : alsa-plugins-pulseaudio-1.1.1-1.el7.x86_64                   6/6
  Verifying  : alsa-utils-1.1.3-2.el7.x86_64                                1/6
  Verifying  : libtdb-1.3.15-1.el7.x86_64                                   2/6
  Verifying  : webrtc-audio-processing-0.3-1.el7.x86_64                     3/6
  Verifying  : rtkit-0.11-10.el7.x86_64                                     4/6
  Verifying  : pulseaudio-10.0-5.el7.x86_64                                 5/6
  Verifying  : alsa-plugins-pulseaudio-1.1.1-1.el7.x86_64                   6/6

Installed:
  alsa-plugins-pulseaudio.x86_64 0:1.1.1-1.el7

Dependency Installed:
  alsa-utils.x86_64 0:1.1.3-2.el7               libtdb.x86_64 0:1.3.15-1.el7
  pulseaudio.x86_64 0:10.0-5.el7                rtkit.x86_64 0:0.11-10.el7
  webrtc-audio-processing.x86_64 0:0.3-1.el7

Complete!

17. libsamplerate-devel for modules/resample

[root@tutorialspots ~]# yum install libsamplerate-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.compevo.com
 * epel: fedora-epel.mirror.lstn.net
 * extras: centos.host-engine.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.mirrors.tds.net
Resolving Dependencies
--> Running transaction check
---> Package libsamplerate-devel.x86_64 0:0.1.8-6.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch          Version             Repository   Size
================================================================================
Installing:
 libsamplerate-devel        x86_64        0.1.8-6.el7         base        9.1 k

Transaction Summary
================================================================================
Install  1 Package

Total download size: 9.1 k
Installed size: 5.5 k
Downloading packages:
libsamplerate-devel-0.1.8-6.el7.x86_64.rpm                 | 9.1 kB   00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libsamplerate-devel-0.1.8-6.el7.x86_64                       1/1
  Verifying  : libsamplerate-devel-0.1.8-6.el7.x86_64                       1/1

Installed:
  libsamplerate-devel.x86_64 0:0.1.8-6.el7

Complete!

18. vid.stab-devel for modules/vid.stab

[root@tutorialspots ~]# yum install -y vid.stab-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.compevo.com
 * epel: fedora-epel.mirror.lstn.net
 * extras: centos.host-engine.com
 * ius: dfw.mirror.rackspace.com
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: mirror.bebout.net
 * updates: centos.mirrors.tds.net
Resolving Dependencies
--> Running transaction check
---> Package vid.stab-devel.x86_64 0:1.1-4.20170830gitafc8ea9.el7 will be instal
led
--> Processing Dependency: vid.stab(x86-64) = 1.1-4.20170830gitafc8ea9.el7 for p
ackage: vid.stab-devel-1.1-4.20170830gitafc8ea9.el7.x86_64
--> Processing Dependency: libvidstab.so.1.1()(64bit) for package: vid.stab-deve
l-1.1-4.20170830gitafc8ea9.el7.x86_64
--> Running transaction check
---> Package vid.stab.x86_64 0:1.1-4.20170830gitafc8ea9.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch       Version                           Repository
                                                                           Size
================================================================================
Installing:
 vid.stab-devel     x86_64     1.1-4.20170830gitafc8ea9.el7      epel      19 k
Installing for dependencies:
 vid.stab           x86_64     1.1-4.20170830gitafc8ea9.el7      epel      45 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 64 k
Installed size: 153 k
Downloading packages:
(1/2): vid.stab-1.1-4.20170830gitafc8ea9.el7.x86_64.rpm    |  45 kB   00:00
(2/2): vid.stab-devel-1.1-4.20170830gitafc8ea9.el7.x86_64. |  19 kB   00:00
--------------------------------------------------------------------------------
Total                                              189 kB/s |  64 kB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : vid.stab-1.1-4.20170830gitafc8ea9.el7.x86_64                 1/2
  Installing : vid.stab-devel-1.1-4.20170830gitafc8ea9.el7.x86_64           2/2
  Verifying  : vid.stab-devel-1.1-4.20170830gitafc8ea9.el7.x86_64           1/2
  Verifying  : vid.stab-1.1-4.20170830gitafc8ea9.el7.x86_64                 2/2

Installed:
  vid.stab-devel.x86_64 0:1.1-4.20170830gitafc8ea9.el7

Dependency Installed:
  vid.stab.x86_64 0:1.1-4.20170830gitafc8ea9.el7

Complete!

19. QT framework for modules/qt

If you use QT4

yum install qt-devel -y
ln -s /usr/lib64/qt4/bin/qmake /usr/bin/qmake

If you use QT5

yum install qt5-devel -y

20. OpenCV for modules/opencv
How to install OpenCV on CentOS 7

Leave a Reply