LINUX: How to find the list of installed packages in YUM


When we need to know the list of installed packages in YUM, we can use the below command line:

yum list installed

The result:

...
httpd-tools.i386                      2.2.27-2                         installed
imake.i386                            1.0.2-3                          installed
info.i386                             4.8-14.el5                       installed
initscripts.i386                      8.45.25-1.el5.centos             installed
initscripts.i386                      8.45.44-3.el5.centos             installed
iproute.i386                          2.6.18-9.el5                     installed
iproute.i386                          2.6.18-15.el5                    installed
iptables.i386                         1.3.5-4.el5                      installed
iptables.i386                         1.3.5-9.2.el5_8                  installed
iputils.i386                          20020927-46.el5                  installed
iscsi-initiator-utils.i386            6.2.0.872-16.el5                 installed
jwhois.i386                           3.2.3-8.el5                      installed
jwhois.i386                           3.2.3-12.el5                     installed
kernel-headers.i386                   2.6.18-371.12.1.el5              installed
keyutils-libs.i386                    1.2-1.el5                        installed
kloxo-core-php.i386                   5.3.28-2                         installed
kpartx.i386                           0.4.7-59.el5_10.2                installed
krb5-libs.i386                        1.6.1-71.el5_10.1                installed
less.i386                             394-5.el5                        installed
less.i386                             436-9.el5                        installed
libFS.i386                            1.0.0-3.1                        installed
libICE.i386                           1.0.1-2.1                        installed
libSM.i386                            1.0.1-3.1                        installed
libX11.i386                           1.0.3-11.el5_7.1                 installed
libXau.i386                           1.0.1-3.1                        installed
libXaw.i386                           1.0.2-8.1                        installed
libXdmcp.i386                         1.0.1-2.1                        installed
libXext.i386                          1.0.1-2.1                        installed
libXfont.i386                         1.2.2-1.0.5.el5_10               installed
libXft.i386                           2.1.10-1.1                       installed
libXmu.i386                           1.0.2-5                          installed
libXpm.i386                           3.5.5-3                          installed
libXrender.i386                       0.9.1-3.1                        installed
libXt.i386                            1.0.2-3.2.el5                    installed
libacl.i386                           2.2.39-3.el5                     installed
libacl.i386                           2.2.39-8.el5                     installed
libart_lgpl.i386                      2.3.17-4                         installed
libattr.i386                          2.4.32-1.1                       installed
libc-client.i386                      2004g-2.2.1                      installed
libcap.i386                           1.10-26                          installed
libevent.i386                         1.4.13-1                         installed
libfontenc.i386                       1.0.2-2.2.el5                    installed
libgcc.i386                           4.1.2-52.el5_8.1                 installed
libgcc.i386                           4.1.2-54.el5                     installed
libgcrypt.i386                        1.2.4-1.el5                      installed
libgcrypt.i386                        1.4.4-7.el5_10                   installed
libgomp.i386                          4.4.7-1.el5                      installed
libgpg-error.i386                     1.4-2                            installed
libidn.i386                           0.6.5-1.1                        installed
libjpeg.i386                          6b-37                            installed
libjpeg.i386                          6b-38                            installed
libmcrypt.i386                        2.5.8-4.el5.centos               installed
libmhash.i386                         0.9.1-1.2.el5.rf                 installed
libpng.i386                           2:1.2.10-7.1.el5_3.2             installed
libpng.i386                           2:1.2.10-17.el5_8                installed
libselinux.i386                       1.33.4-5.1.el5                   installed
libselinux.i386                       1.33.4-5.7.el5                   installed
libselinux-python.i386                1.33.4-5.1.el5                   installed
libselinux-python.i386                1.33.4-5.7.el5                   installed
libselinux-utils.i386                 1.33.4-5.1.el5                   installed
libselinux-utils.i386                 1.33.4-5.7.el5                   installed
libsemanage.i386                      1.9.1-3.el5                      installed
libsemanage.i386                      1.9.1-4.4.el5                    installed
libsepol.i386                         1.15.2-1.el5                     installed
libsepol.i386                         1.15.2-3.el5                     installed
libsrs2-toaster.i386                  1.0.18-1.3.3                     installed
libsrs2-toaster.i386                  1.0.18-1.3.6                     installed
libstdc++.i386                        4.1.2-52.el5_8.1                 installed
libstdc++.i386                        4.1.2-54.el5                     installed
libstdc++-devel.i386                  4.1.2-52.el5_8.1                 installed
libstdc++-devel.i386                  4.1.2-54.el5                     installed
libsysfs.i386                         2.1.0-1.el5                      installed
libtermcap.i386                       2.0.8-46.1                       installed
libtiff.i386                          3.8.2-7.el5_2.2                  installed
libtiff.i386                          3.8.2-19.el5_10                  installed
libtool.i386                          1.5.22-7.el5_4                   installed
libtool-ltdl.i386                     1.5.22-7.el5_4                   installed
libusb.i386                           0.1.12-5.1                       installed
libusb.i386                           0.1.12-6.el5                     installed
libuser.i386                          0.54.7-2.el5.5                   installed
libuser.i386                          0.54.7-3.el5                     installed
libutempter.i386                      1.1.4-4.el5                      installed
libxml2.i386                          2.6.26-2.1.2.7                   installed
libxml2.i386                          2.6.26-2.1.21.el5_9.3            installed
libxml2-python.i386                   2.6.26-2.1.2.7                   installed
libxml2-python.i386                   2.6.26-2.1.21.el5_9.3            installed
libxslt.i386                          1.1.17-4.el5_8.3                 installed
lm_sensors.i386                       2.10.7-9.el5                     installed
logrotate.i386                        3.7.4-9                          installed
logrotate.i386                        3.7.4-14                         installed
lsof.i386                             4.78-3                           installed
lsof.i386                             4.78-6                           installed
lua.i386                              5.1.4-4.el5                      installed
lvm2.i386                             2.02.88-12.el5                   installed
lxjailshell.i386                      3.2-33                           installed
lxlighttpd.i386                       1.4.29-1                         installed
lxlighttpd.i386                       1.4.32-1                         installed
lxzend.i386                           3.3-100lxa                       installed
lynx.i386                             2.8.5-28.1.el5_2.1               installed
m2crypto.i386                         0.16-6.el5.3                     installed
m2crypto.i386                         0.16-9.el5                       installed
m4.i386                               1.4.5-3.el5.1                    installed
mailcap.noarch                        2.1.23-1.fc6                     installed
maildrop-toaster.i386                 2.0.3-1.3.5                      installed
maildrop-toaster.i386                 2.0.3-1.3.8                      installed
mailx.i386                            8.1.1-44.2.2                     installed
make.i386                             1:3.81-3.el5                     installed
man.i386                              1.6d-1.1                         installed
man.i386                              1.6d-3.el5                       installed
man-pages.noarch                      2.39-12.el5                      installed
man-pages.noarch                      2.39-20.el5                      installed
mcstrans.i386                         0.2.11-3.el5                     installed
mingetty.i386                         1.07-5.2.2                       installed
mkinitrd.i386                         5.1.19.6-81.el5_10               installed
mktemp.i386                           3:1.5-23.2.2                     installed
mktemp.i386                           3:1.5-24.el5                     installed
mlocate.i386                          0.15-1.el5.1                     installed
mlocate.i386                          0.15-1.el5.2                     installed
mod_ssl.i386                          1:2.2.27-2                       installed
module-init-tools.i386                3.3-0.pre3.1.42.el5              installed
module-init-tools.i386                3.3-0.pre3.1.63.el5              installed
mysql.i386                            5.0.95-1.el5_7.1                 installed
mysql.i386                            5.0.96-1                         installed
mysql-server.i386                     5.0.95-1.el5_7.1                 installed
mysql-server.i386                     5.0.96-1                         installed
nano.i386                             1.3.12-1.1                       installed
nash.i386                             5.1.19.6-81.el5_10               installed
ncompress.i386                        4.2.4-47                         installed
ncurses.i386                          5.5-24.20060715                  installed
net-snmp.i386                         1:5.3.2.2-22.el5_10.1            installed
net-snmp-libs.i386                    1:5.3.2.2-22.el5_10.1            installed
net-snmp-utils.i386                   1:5.3.2.2-22.el5_10.1            installed
net-tools.i386                        1.60-83.el5_10                   installed
newt.i386                             0.52.2-12.el5                    installed
newt.i386                             0.52.2-15.el5                    installed
nscd.i386                             2.5-118.el5_10.3                 installed
nspr.i386                             4.10.6-1.el5_10                  installed
nss.i386                              3.15.3-7.el5_10                  installed
ntsysv.i386                           1.3.30.1-2                       installed
ntsysv.i386                           1.3.30.2-2.el5                   installed
openldap.i386                         2.3.43-28.el5_10                 installed
openssh.i386                          4.3p2-29.el5                     installed
openssh.i386                          4.3p2-82.el5                     installed
openssh-clients.i386                  4.3p2-29.el5                     installed
openssh-server.i386                   4.3p2-29.el5                     installed
openssl.i686                          0.9.8e-27.el5_10.4               installed
pam.i386                              0.99.6.2-4.el5                   installed
pam.i386                              0.99.6.2-12.el5                  installed
pango.i386                            1.14.9-8.el5.centos.3            installed
passwd.i386                           0.73-1                           installed
passwd.i386                           0.73-2                           installed
pcre.i386                             6.6-2.el5_1.7                    installed
pcre.i386                             8.02-1.el5_5.1                   installed
perl.i386                             4:5.8.8-18.el5_3.1               installed
perl.i386                             4:5.8.8-41.el5                   installed
perl-Archive-Tar.noarch               1:1.39.1-1.el5_5.2               installed
perl-Compress-Zlib.i386               1.42-1.fc6                       installed
perl-Convert-ASN1.noarch              0.20-1.1                         installed
perl-DBD-MySQL.i386                   3.0007-2.el5                     installed
perl-DBI.i386                         1.52-2.el5                       installed
perl-Digest-HMAC.noarch               1.01-15                          installed
perl-Digest-SHA1.i386                 2.11-1.2.1                       installed
perl-HTML-Parser.i386                 3.55-1.fc6                       installed
perl-HTML-Tagset.noarch               3.10-2.1.1                       installed
perl-IO-Socket-INET6.noarch           2.51-2.fc6                       installed
perl-IO-Socket-SSL.noarch             1.01-1.fc6                       installed
perl-IO-Socket-SSL.noarch             1.01-2.el5                       installed
perl-IO-Zlib.noarch                   1.04-4.2.1                       installed
perl-Net-DNS.i386                     0.59-3.el5                       installed
perl-Net-IP.noarch                    1.25-2.fc6                       installed
perl-Net-SSLeay.i386                  1.30-4.fc6                       installed
perl-NetAddr-IP.i386                  4.043-1.el5.rf                   installed
perl-Socket6.i386                     0.19-3.fc6                       installed
perl-URI.noarch                       1.35-3                           installed
perl-libwww-perl.noarch               5.805-1.1.1                      installed
perl-rrdtool.i386                     1.2.23-1.el5.rf                  installed
perl-rrdtool.i386                     1.4.7-1                          installed
php.i386                              5.2.17-37                        installed
php-cli.i386                          5.2.17-37                        installed
php-common.i386                       5.2.17-37                        installed
php-devel.i386                        5.2.17-37                        installed
php-gd.i386                           5.2.17-37                        installed
php-imap.i386                         5.2.17-37                        installed
php-mbstring.i386                     5.2.17-37                        installed
php-mcrypt.i386                       5.2.17-37                        installed
php-mysql.i386                        5.2.17-37                        installed
php-pdo.i386                          5.2.17-37                        installed
php-pear.noarch                       1:1.9.4-23                       installed
php-process.i386                      5.2.17-37                        installed
php-xml.i386                          5.2.17-37                        installed
pkgconfig.i386                        1:0.21-2.el5                     installed
policycoreutils.i386                  1.33.12-14.2.el5                 installed
policycoreutils.i386                  1.33.12-14.13.el5                installed
popt.i386                             1.10.2.3-9.el5                   installed
popt.i386                             1.10.2.3-34.el5                  installed
portmap.i386                          4.0-65.2.2.1                     installed
postgresql-libs.i386                  8.1.11-1.el5_1.1                 installed
postgresql-libs.i386                  8.1.23-10.el5_10                 installed
procmail.i386                         3.22-17.1.2.el5_10               installed
procps.i386                           3.2.7-11.1.el5                   installed
procps.i386                           3.2.7-26.el5                     installed
psmisc.i386                           22.2-6                           installed
psmisc.i386                           22.2-11                          installed
pure-ftpd.i386                        1.0.36-1.lxcenter                installed
python.i386                           2.4.3-24.el5                     installed
python.i386                           2.4.3-56.el5                     installed
python-elementtree.i386               1.2.6-5                          installed
python-iniparse.noarch                0.2.3-4.el5                      installed
python-iniparse.noarch                0.2.3-6.el5                      installed
python-libs.i386                      2.4.3-56.el5                     installed
python-sqlite.i386                    1.1.7-1.2.1                      installed
python-urlgrabber.noarch              3.1.0-5.el5                      installed
python-urlgrabber.noarch              3.1.0-6.el5                      installed
qmail.i386                            1.03-1.5.15                      installed
quota.i386                            1:3.13-1.2.5.el5                 installed
quota.i386                            1:3.13-8.el5                     installed
readline.i386                         5.1-1.1                          installed
readline.i386                         5.1-3.el5                        installed
redhat-logos.noarch                   4.9.99-11.el5.centos             installed
ripmime-toaster.i386                  1.4.0.6-1.3.3                    installed
ripmime-toaster.i386                  1.4.0.6-1.3.6                    installed
rootfiles.noarch                      8.1-1.1.1                        installed
rpm.i386                              4.4.2.3-9.el5                    installed
rpm.i386                              4.4.2.3-34.el5                   installed
rpm-libs.i386                         4.4.2.3-9.el5                    installed
rpm-libs.i386                         4.4.2.3-34.el5                   installed
rpm-python.i386                       4.4.2.3-9.el5                    installed
rpm-python.i386                       4.4.2.3-34.el5                   installed
rrdtool.i386                          1.2.23-1.el5.rf                  installed
rrdtool.i386                          1.4.7-1                          installed
rsync.i386                            2.6.8-3.1                        installed
rsync.i386                            3.0.6-4.el5_7.1                  installed
ruby.i386                             1.8.5-31.el5_9                   installed
ruby-libs.i386                        1.8.5-31.el5_9                   installed
safecat.i386                          1.05-EL5                         installed
screen.i386                           4.0.3-1.el5                      installed
screen.i386                           4.0.3-4.el5                      installed
sed.i386                              4.1.5-5.fc6                      installed
sed.i386                              4.1.5-8.el5                      installed
setup.noarch                          2.5.58-4.el5                     installed
setup.noarch                          2.5.58-9.el5                     installed
setuptool.i386                        1.19.2-1.el5.centos              installed
sgpio.i386                            1.2.0_10-2.el5                   installed
shadow-utils.i386                     2:4.0.17-14.el5                  installed
shadow-utils.i386                     2:4.0.17-21.el5                  installed
sharutils.i386                        4.6.1-2                          installed
simscan-toaster.i386                  1.4.0-1.3.8                      installed
simscan-toaster.i386                  1.4.0-1.4.0                      installed
slang.i386                            2.0.6-4.el5                      installed
spamdyke.i386                         4.2.0-0.lxcenter                 installed
spamdyke.i386                         4.3.1-3.lxcenter                 installed
spamdyke-utils.i386                   4.2.0-0.lxcenter                 installed
spamdyke-utils.i386                   4.3.1-3.lxcenter                 installed
sqlite.i386                           3.3.6-2                          installed
sqlite.i386                           3.3.6-7                          installed
stunnel.i386                          4.15-2.el5.1                     installed
sudo.i386                             1.6.9p17-3.el5_3.1               installed
sudo.i386                             1.7.2p1-29.el5_10                installed
sysklogd.i386                         1.4.1-44.el5                     installed
sysklogd.i386                         1.4.1-46.el5                     installed
t1lib.i386                            5.1.1-7.el5                      installed
talk.i386                             0.17-29.2.2                      installed
talk.i386                             0.17-31.el5                      installed
talk-server.i386                      0.17-29.2.2                      installed
talk-server.i386                      0.17-31.el5                      installed
tar.i386                              2:1.15.1-32.el5_8                installed
tcl.i386                              8.4.13-4.el5                     installed
tcl.i386                              8.4.13-6.el5                     installed
tcp_wrappers.i386                     7.6-40.6.el5                     installed
tcp_wrappers.i386                     7.6-40.7.el5                     installed
tcpdump.i386                          14:3.9.4-15.el5                  installed
tcsh.i386                             6.14-14.el5                      installed
tcsh.i386                             6.14-17.el5_5.2                  installed
telnet.i386                           1:0.17-41.el5                    installed
termcap.noarch                        1:5.5-1.20060701.1               installed
time.i386                             1.7-27.2.2                       installed
tmpwatch.i386                         2.9.7-1.1.el5.2                  installed
tmpwatch.i386                         2.9.7-1.1.el5.5                  installed
traceroute.i386                       3:2.0.1-5.el5                    installed
traceroute.i386                       3:2.0.1-6.el5                    installed
ttmkfdir.i386                         3.0.9-23.el5                     installed
tzdata.i386                           2014e-1.el5                      installed
ucspi-tcp-toaster.i386                0.88-1.3.5                       installed
ucspi-tcp-toaster.i386                0.88-1.3.9                       installed
udev.i386                             095-14.19.el5                    installed
udev.i386                             095-14.29.el5                    installed
unzip.i386                            5.52-3.el5                       installed
usermode.i386                         1.88-3.el5.2                     installed
util-linux.i386                       2.13-0.50.el5                    installed
util-linux.i386                       2.13-0.59.el5_8                  installed
vim-common.i386                       2:7.0.109-4.el5_2.4z             installed
vim-common.i386                       2:7.0.109-7.2.el5                installed
vim-enhanced.i386                     2:7.0.109-4.el5_2.4z             installed
vim-enhanced.i386                     2:7.0.109-7.2.el5                installed
vim-minimal.i386                      2:7.0.109-4.el5_2.4z             installed
vim-minimal.i386                      2:7.0.109-7.2.el5                installed
vixie-cron.i386                       4:4.1-76.el5                     installed
vixie-cron.i386                       4:4.1-81.el5                     installed
vpopmail.i386                         5.4.17-1.6.4                     installed
vzdev.noarch                          1.0-7.swsoft                     installed
vzdummy-apache.noarch                 1.0-1.swsoft                     installed
vzdummy-glibc.noarch                  1.0-1.swsoft                     installed
vzdummy-jre-el5.noarch                1.0-1.swsoft                     installed
vzdummy-kernel-el5.noarch             2.0-1.ce.swsoft                  installed
webalizer.i386                        2.01_10-30.1                     installed
wget.i386                             1.11.4-3.el5_8.2                 installed
which.i386                            2.16-7                           installed
xinetd.i386                           2:2.3.14-10.el5                  installed
xinetd.i386                           2:2.3.14-20.el5_10               installed
xorg-x11-filesystem.noarch            7.1-2.fc6                        installed
xorg-x11-font-utils.i386              1:7.1-3                          installed
xorg-x11-fonts-Type1.noarch           7.1-2.1.el5                      installed
xorg-x11-xfs.i386                     1:1.0.2-5.el5_6.1                installed
yum.noarch                            3.2.19-18.el5.centos             installed
yum.noarch                            3.2.22-40.el5.centos             installed
yum-fastestmirror.noarch              1.1.16-13.el5.centos             installed
yum-fastestmirror.noarch              1.1.16-21.el5.centos             installed
yum-metadata-parser.i386              1.1.2-2.el5                      installed
yum-metadata-parser.i386              1.1.2-4.el5                      installed
yum-plugin-replace.noarch             0.2.5-1.ius                      installed
yum-protectbase.noarch                1.1.16-21.el5.centos             installed
zip.i386                              2.31-2.el5                       installed
zlib.i386                             1.2.3-3                          installed
zlib.i386                             1.2.3-7.el5                      installed

yum list installed

The list is so long! We can’t scroll up to view the above packages.

To view all installed packages, following the below command:

yum list installed | more

Press enter to view more installed package.

How to check if the specific package is installed in yum?

There are many ways to check that.
Specific example: Check the package php:

Method 1:

yum list installed | grep ^php\\.

Result:

[root@tutorialspots.com ~]# yum list installed | grep ^php\\.
php.i386                              5.2.17-37                        installed

Method 2:

rpm -qa | grep ^php\\-[0-9]

Result:

[root@tutorialspots.com ~]# rpm -qa | grep ^php\\-[0-9]
php-5.2.17-37

Method 3:

rpm -q php

Result:

[root@tutorialspots.com ~]# rpm -q php
php-5.2.17-37

Method 4:

yum info php | grep Version

Result:

[root@tutorialspots.com ~]# yum info php | grep Version
Version    : 5.2.17

Related Post

,

No comments yet.

Leave a Reply